Image API Performance Degradation

Incident Report for Topaz Labs

Resolved

Queue times have returned to normal values
Posted Feb 25, 2026 - 17:43 UTC

Monitoring

We are seeing a decrease in queue times for image requests. The impact on video requests has been resolved.

Our engineers will continue to monitor queue times.
Posted Feb 25, 2026 - 17:01 UTC

Update

We have identified Video workloads that may be affected, and are working to move the workloads to another provider.
Posted Feb 25, 2026 - 16:50 UTC

Identified

An issue at an upstream hosting provider is causing increased queue times for the image API. Our engineers are working to move affected workloads to another provider.
Posted Feb 25, 2026 - 16:48 UTC
This incident affected: API (Image API).