Image API High Queue Times

Incident Report for Topaz Labs

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 19:57 UTC

Update

We are continuing to investigate this issue.
Posted Mar 16, 2026 - 19:53 UTC

Update

The issue has been resolved and the queue has been cleared.
Posted Mar 16, 2026 - 19:53 UTC

Investigating

Our cloud services are currently experiencing high queue times for the following models:
- Adjust V2
- Auto Sharpen
- Bloom
- Bloom Precision
- Bloom Realism
- Colorize
- Detail
- Dust-Scratch V2
- Natural Enhance
- Object
- Portrait
- Recover 3
- Redefine
- Starlight Precise 2
- Transparency Upscale
- Wildlife
- Wonder 2

If you experience request failures, please retry the request.
Posted Mar 16, 2026 - 16:02 UTC
This incident affected: API (Image API).