Login Issues

Incident Report for Topaz Labs

Resolved

A fix has been released for the affected desktop app
Posted Mar 12, 2026 - 01:58 UTC

Update

We are receiving reports of continuing login issues for some desktop apps. Our engineers are working to deploy a fix
Posted Mar 11, 2026 - 16:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2026 - 15:24 UTC

Investigating

Our engineers are investigating reports of issues with login and account creation
Posted Mar 11, 2026 - 15:08 UTC
This incident affected: Website (Accounts), API (Authorization and Billing Services), and Astra, Web Apps.